Author Topic: freebsd 11 repo failed pkg update and found error for wrong version 2  (Read 1612 times)

golfreeze

  • Administrator
  • Hero Member
  • *****
  • Posts: 2138
    • View Profile
    • นั่งสมาธิ สติปัฏฐานสี่ พาเที่ยววัด แนะนำวัด แจกcd ธรรมะฟรี
    • Email
freebsd 11 repo failed pkg update and found error for wrong version 2
« on: มิถุนายน 03, 2020, 11:17:57 AM »
#pkg update and found error for wrong version and repo information
pkg: repository meta /var/db/pkg/FreeBSD.meta has wrong version 2

=== fixed by
#pkg bootstrap -f
#pkg update -f
#pkg upgrade

or
#pkg install rsync

== then update path
/usr/libexec/locate.updatedb

==rsync installed done.
# rsync --version
rsync  version 3.1.3  protocol version 31
Copyright (C) 1996-2018 by Andrew Tridgell, Wayne Davison, and others.
Web site: http://rsync.samba.org/
Capabilities:
    64-bit files, 32-bit inums, 64-bit timestamps, 64-bit long ints,
    socketpairs, hardlinks, symlinks, IPv6, batchfiles, inplace,
    append, ACLs, xattrs, iconv, symtimes, no prealloc, file-flags

rsync comes with ABSOLUTELY NO WARRANTY.  This is free software, and you
are welcome to redistribute it under certain conditions.  See the GNU
General Public Licence for details.
« Last Edit: มิถุนายน 03, 2020, 11:20:40 AM by golfreeze »