Author Topic: struts2 on framework vulnerable for upload command then run bash  (Read 1757 times)

golfreeze

  • Administrator
  • Hero Member
  • *****
  • Posts: 2035
    • View Profile
    • นั่งสมาธิ สติปัฏฐานสี่ พาเที่ยววัด แนะนำวัด แจกcd ธรรมะฟรี
    • Email
struts2 on framework vulnerable for upload command then run bash
« on: เมษายน 19, 2017, 03:44:07 PM »
https://github.com/fredondiek/struts2_rce_attack_filter
https://github.com/rapid7/metasploit-framework/issues/8064

It is possible to perform a RCE attack with a malicious Content-Type value. If the Content-Type value isn't valid an exception is thrown which is then used to display an error message to a user.

อาจจะโดนอยู่ใน

/var/tmp
หรือ
/usr/local/tomcat
ได้นะครับผม